
There are animations for the 1d case here:

http://mathworld.wolfram.com/Convolution.html
http://en.wikipedia.org/wiki/Convolution

http://www.jhu.edu/signals/convolve/index.html
Draw a comb for x(t) and and a simple shape for h(t)
You will see that the convolution places a copy of h(t) at the location of each delta function.
Of course, you already saw that for 2d with http://escher.epfl.ch/fft/ 
The jhu discrete case is illustrated here
http://www.jhu.edu/signals/discreteconv2/index.html   

The 2d case is explained here:

Kevin Cowan explains the convolution theorem here.
http://www.ysbl.york.ac.uk/~cowtan/fourier/convthry.html
Ignore the stuff not about ducks.   :-)

The Fourier transform of the Dirac comb, aka Shah function, comb, sampling function, ……

http://en.wikipedia.org/wiki/Dirac_comb
http://mathworld.wolfram.com/ShahFunction.html

In 1d, the FT of the Dirac comb in time is a Dirac comb in frequency
In 1d, the FT of the Dirac comb in space is a Dirac comb in spatial frequency
In spatial 2d or 3d, the Dirac comb is the real space lattice and its FT is the reciprocal space lattice
In 2d, the Dirac delta functions are two-dimensional
In 3d, the Dirac delta functions are three-dimensional

For electrical engineering:

http://en.wikipedia.org/wiki/LTI_system_theory
The essential idea is shown in the first figure.
The figure illustrates the convolution theorem for the Laplace theorem.
The theorem is exactly the same for the Fourier transform.
After all, the Fourier transform is precisely the Laplace transform rotated 90 degrees in the complex plane.   :-)

www.stanford.edu/~boyd/ee102/freq.pdf

http://dsp.stackexchange.com/questions/536/what-is-meant-by-a-systems-impulse-response-and-frequency-response

Bang on something sharply once and plot how it responds in the time domain. That will be close to the impulse response.

An LTI system's impulse response and frequency response are intimately related. The frequency response is simply the 
Fourier transform of the system's impulse response.  So, given either a system's impulse response or its frequency response, 
you can calculate the other. Either one is sufficient to fully characterize the behavior of the system; the impulse response is 
useful when operating in the time domain and the frequency response is useful when analyzing behavior in the frequency 
domain.

Some Video Lectures:

http://www.youtube.com/watch?v=cm9W10Kg8q4
http://www.youtube.com/watch?v=WF9ftfGEGYw
http://www.youtube.com/watch?v=RkRYe1J7cHE
http://www.youtube.com/watch?v=qh29mj6uXoM
http://www.youtube.com/watch?v=2je6p4_-lEI
http://www.youtube.com/watch?v=I3s5HFQ2YME

http://mathworld.wolfram.com/Convolution.html
http://en.wikipedia.org/wiki/Convolution
http://www.jhu.edu/signals/convolve/index.html
http://escher.epfl.ch/fft/
http://escher.epfl.ch/fft/
http://www.jhu.edu/signals/discreteconv2/index.html
http://www.ysbl.york.ac.uk/~cowtan/fourier/convthry.html
http://en.wikipedia.org/wiki/Dirac_comb
http://mathworld.wolfram.com/ShahFunction.html
http://en.wikipedia.org/wiki/LTI_system_theory
http://www.stanford.edu/~boyd/ee102/freq.pdf
http://dsp.stackexchange.com/questions/536/what-is-meant-by-a-systems-impulse-response-and-frequency-response
http://www.youtube.com/watch?v=cm9W10Kg8q4
http://www.youtube.com/watch?v=WF9ftfGEGYw
http://www.youtube.com/watch?v=RkRYe1J7cHE
http://www.youtube.com/watch?v=qh29mj6uXoM
http://www.youtube.com/watch?v=2je6p4_-lEI
http://www.youtube.com/watch?v=I3s5HFQ2YME
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because the M‐band carries relatively little mass. In the I‐band, the
contributors are the remainder of the actin filaments, the tetragonal
Z‐band, and possibly the I‐band parts of titin. In order to explain and
understand the various contributions that these different structures make,
the following section assesses the diffraction effects of each of the major
components.
The background ideas about muscle structure and the crossbridge cycle,

together with some historical perspectives, are discussed in this volume in
Squire et al. (2005) and Geeves and Holmes (2005) and also, for example,
in Huxley (1969, 2004), Holmes (1997), Geeves and Holmes (1999), and
the special Royal Society issue on ‘‘Myosin, Muscle and Motility’’ (Phil.
Trans. Roy. Soc. B. volume 359, pp 1811–1964).

B. Factors Affecting Diffraction Patterns

1. General Ideas About Diffraction

Although this volume is not primarily intended as a techniques book, it
will probably be helpful here to summarize in a qualitative way for those
who are non‐experts in the basic aspects of diffraction theory that are used
later in this article. Those who already have a thorough understanding of
the technique should proceed directly to Section I.C.
Figure 1 summarizes the basic concept underlying all diffraction meth-

ods. Whether the radiation being used is X‐rays, neutrons, electrons, or
visible light, it can be described in terms of a wave of oscillating amplitude
(y) with a maximum amplitude a, and with a wavelength l. These waves can
be imagined as propagating across space in the x direction as in Fig. 1A. If
two such waves with the same wavelength arrive at the same point with their
peaks and troughs in step (they are said to be in phase), then the ampli-
tudes add and a wave of larger amplitude results (Fig. 1B). This is called
constructive interference. However, if the peaks of one coincide with the
troughs of the other (they are exactly out of phase), then destructive
interference occurs (Fig. 1C). Often such peaks will be neither exactly in
phase nor exactly out of phase and they sum to give an intermediate or
partial amplitude as in Fig. 1D.
If a beam of light with a wavelength of, say �5000 Å, falls onto a card

with two small holes a distance d apart (Fig. 2), then each hole will scatter
the light in all directions. In a particular direction at the angle f the ways
that the light scattered from the two holes adds up depends on how in
phase or out of phase the two beams are. This can be determined by the
size of d sinf, which is the extra distance the beam from X must travel
relative to the beam from Y. Obviously, if the two waves add up after being
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shifted by a whole wavelength or any integer multiple of the wavelength
(nl), then constructive interference will occur (Fig.1B). So if d sinf is the
same as nl, then an intense peak will be seen on a screen placed on the
right hand side of Fig. 2A. In general, if d sinf 6¼ nl, then partial or
destructive interference occurs. Fig. 2B–E show various situations where
the path difference d sinf is (B) 0 (n¼ 0), (C) l/2 (n¼ 0.5), (D) l (n¼ 1),
and (E) 2l (n ¼ 2). In summary, the condition d sinf ¼ nl produces a
series of intensity peaks on the screen for varying values of n. This is
described as the diffraction pattern from the array of holes.

The condition d sinf ¼ nl, sometimes known as the grating equation, has
some interesting implications. For a given wavelength of radiation, if the
separation of the holes d is larger, then the value of f needed for construc-
tive interference is smaller and vice versa (i.e., sinf / 1/d). This is often
described in terms of the reciprocal nature of diffraction. Also noteworthy is
that if the wavelength increases, then the whole diffraction pattern gets
bigger as well. Most importantly, if f can be measured and l is known, then
the distance d can be calculated.

Fig. 1. Summary of the ideas of interference. (A) Wave profile with wavelength l and
amplitude a. (B) Constructive interference from waves moving in the x direction where
the amplitude (a) of the two waves varies in step (or in phase). (C) destructive interfer-
ence by waves out of step by half a wavelength (l/2), and (D) partial reinforcement by
waves not exactly in phase or out of phase.
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2. Diffraction from Crystals

The next step to think about is what happens if the radiation is, say, an
X‐ray beam (with a wavelength of 1–2 Å) and this falls onto an array of
atoms in a crystal rather than holes. This situation is illustrated in Fig. 3A.
What happens when the X‐rays arrive at the atoms is that the electrons
in the atoms are caused to oscillate by the alternating electric field in the
X‐ray beam and such oscillating charged particles themselves radiate at the
same wavelength as the incident radiation, but in all directions. Consider-
ing the top plane of atoms in Fig. 3A, including the atom at O, then each of
these atoms will be stimulated by the incoming X‐ray beam and will radiate
in all directions at the same wavelength l. It is easy to show that the
radiation incident at a particular angle y is scattered most strongly in a

Fig. 2. (A) Scattering from two small holes at points X and Y a distance d apart in an
opaque card, and (B) to (E) the effects of the angle of scatter (f) on whether the two
waves are in phase or out of phase. Path differences are (B) zero (in phase), (C) l/2 (out
of phase), (D) l (in phase), (E) 2l (in phase).
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Fig. 3. (A) Scattering of an X‐ray beam from planes of atoms in a crystal. Scattering
from the atoms (atom planes) at O and B has a path difference of 2d siny, giving rise to
Bragg’s law (nl¼ 2d siny). The angle of incidence is y; the diffraction angle between the
incident and diffracted beam is 2y. (B) Geometry of a typical fiber diffraction experi-
ment. The radiation used (e.g., X‐rays or neutrons) comes in from the left and passes
through the fiber. Molecules in the fiber scatter the radiation onto a film or detector at a
distance D from the fiber. The pattern of spots on the detector can be related to the
organization of the molecules in the fiber. Spots at a position S from the center of the
diffraction pattern are diffracted through an angle given by Tan 2y ¼ S/D. This,
combined with Bragg’s law can yield the value of d corresponding to the peak at S.
Typical fiber patterns have a meridian, parallel to the fiber axis through the undiffracted
beam direction (center), an equator at right angles to this through the center, and a
series of layer lines (horizontal) parallel with the equator. These layer lines may have
continuous intensity along them, or if the fiber is well ordered they may be sampled on
vertical row‐lines to give diffraction spots along the layer lines.
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direction that is also at an angle y to the plane of atoms. In most other
directions there is destructive interference. It is almost as if the X‐rays have
been reflected by the plane of atoms. What happens now if there is a second
plane a distance d below the first plane and reflecting like the first? Fig. 3A
shows the geometry involved. In this case, the two beams going off to the
right at angle y are such that the beam from B has had to travel the extra
distance AB þ BC relative to the beam from O to reach a screen or film on
the right. Obviously if ABþ BC is a whole number of wavelengths, l, then a
constructive interference would be expected to occur. From the figure it is
clear that AB and BC are both d sin y, so we now have the rule for
diffraction (constructive interference) from a crystal: 2d siny ¼ nl. This
is Bragg’s law. Note that as well as the reciprocal relationship that we had
before, and the change of size of the diffraction pattern with l, there is an
additional condition in this case. The condition is that if the crystal planes
of spacing d are not at the angle y as in Bragg’s law above, then those
particular planes will not diffract. A single crystal needs to be turned
relative to the incident direction of a monochromatic (single wavelength)
X‐ray beam in order to get diffraction from particular planes of atoms.
However, when diffraction is seen, measurement of the angle of diffraction
(the angle 2y between the incident and diffracted beams) then permits
calculation of the value of d for those planes, assuming that the wavelength
is known (Fig. 3B).

3. Description of Lattice Planes

A 3D crystal has its atoms arranged such that many different planes can
be drawn through them. It is convenient to be able to describe these
planes in a systematic way and Fig. 4 shows how this is done. It illustrates a
2D example, but the same principle applies to the third dimension. The
crystal lattice can be defined in terms of vectors a and b, which have a
defined length and angle between them (it is c in the third dimension).
The box defined by a and b (and c for 3D) is known as the unit cell. The
dashed lines in Fig. 4A show one set of lines that can be drawn through the
2D lattice (they would be planes in 3D). It can be seen that these lines chop
a into 1 piece and b into 1 piece, so these are called the 11 lines. The lines in
B, however, chop a into 2 pieces, but still chop b into 1 piece, so these are
the 21 lines. If the lines are parallel to an axis as in C, then they do not chop
that axis into any pieces so, in C, the lines chopping a into 1 piece and
which are parallel to b are the 10 lines. This is a simple rule. The numbers
that are generated are known as the Miller indices of the plane. Note that if
the structure in Fig. 6.4 was a 3D crystal viewed down the c axis, the lines
would be planes. In these cases, the third Miller index would be zero (i.e.,
the planes would be the 110 planes in A, the 210 planes in B, and the 100
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planes in C). The Miller indices are also represented in general by the italic
letters h, k, and l.

4. Intensity of Diffraction Peaks: The Convolution Theorem

One of the obvious features of diffraction patterns is that the diffracted
peaks do not all have the same intensity. We can see partly why this is from
the illustration in Fig. 5. Figure 5A represents a 2D lattice (as in Fig. 4), and
D shows the sort of diffraction pattern that would be observed if the
scattering object in Fig. 2A was a mask of holes arrayed as in Fig. 5A and
the diffraction pattern was viewed on the screen. The positions of the spots
in Fig. 5D are totally defined by the arrangement of the objects in A, that is,
by a, b, and the angle between them. However, real crystals have some

Fig. 4. Demonstration of the definitions if Miller indices describing different planes
through a lattice. For details, see text.
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interesting objects (e.g., Fig. 5B) within each unit cell (Fig. 5C). It is
convenient to think about the full crystal (C) as what is termed a convolu-
tion. Literally this means ‘‘folding together.’’ If the object in B is picked up
and placed on every point on the lattice in A, then the structure in C is
generated. This is called the convolution ( * ) of B with A. In short, C¼ (A) *
(B). It can be shownmathematically, and is illustrated in Fig. 5D–F, that the
diffraction pattern (G(C)) from C is then the product of the diffraction
patterns G(A) and G(B) from A and B, respectively. In short: If (c) ¼ (a) *
(c), then G(c) ¼ G(a) � G(c); or, in words, as in Fig. 5, ‘‘IF lattice * object
¼ crystal, THEN lattice transform � object transform ¼ crystal transform.’’
The term transform here is the mathematical equivalent of the diffraction
pattern. This rule is known as the convolution theorem.
The way that the product of the two diffraction patterns D and E is

produced is such that they are placed on top of each other with their
centers together and then multiplied point‐for‐point. This means that
where there is zero in either pattern there is zero also in F. The result is

Fig. 5. Illustration of the convolution theorem applied to a crystal structure and its
diffraction pattern. (A) is a lattice and (B) is the motif or repeating unit on the lattice.
The full crystal (C) is a convolution of (A) and (B). The diffraction pattern (F) of the
crystal (C) is the product of the diffraction patterns (Fourier transforms) (D) and (E)
from (A) and (A), respectively. For details, see text. (Based on Squire, 1981.)
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that F consists of peaks in the positions defined by D, but the intensities of
these peaks are determined by the intensities in E at those particular
positions. The ‘‘take‐home message’’ from this is that the positions of
observed diffraction peaks tell us about the lattice and unit cell in the
crystal (A), whereas the intensities of the peaks tell us about the structure
of the object (B) on the lattice. This object is variously described in the
literature as the motif, or the unit cell contents, or the asymmetric unit.
Following from this, if the intensities of the peaks in (F) can be measured
for a real crystal, then it is possible to work out the structure of the object in
(B). This is what is done in the technique of protein crystallography (e.g.,
Blow, 2002).

5. Effects of the Extent of a Lattice

Before embarking on the diffraction patterns produced by the objects in
the muscle sarcomere, it is necessary to illustrate one other feature of
diffraction patterns. Figure 6 shows various objects as in Fig. 2A and their
computed diffraction patterns. The objects are like the mask of holes a
distance d apart as in Fig. 2A, but this time there are different numbers of
holes. In Fig. 6A there are 3 holes, in C there are 7 holes, and in E there are
10 holes. Since it is assumed that the wavelength of the light being scattered
in these examples is the same, and all the objects have the same interhole
spacing d, the grating equation d sinf ¼ nl from Fig. 2A still applies to
each of them. This means that the diffraction patterns on the right of Fig. 6
all have peaks in exactly the same place. However, the width of the peaks
changes. If there are only three objects as in Fig. 6A, then there are many
directions each side of the main peaks in the pattern where the partial
interference still leaves a significant amount of intensity. The peaks in
Fig. 6B are therefore quite broad. On the other hand, as the number of
objects increases, the partials become much weaker and the diffraction
peaks become progressively narrower. If the length of the whole array is W,
then the width of the observed peaks can be expected to be related to 1/W
(the reciprocal nature of diffraction). 1/W10 is therefore very small com-
pared with 1/W3, with 1/W7 lying between the two. In summary, the width
of an observed diffraction peak can be related to the length of the array
giving rise to the peak. Short arrays give broad peaks, large arrays give sharp
peaks.

This armory affords consideration of the diffraction from the compo-
nents of the muscle sarcomere. Note first that muscles are not single
crystals of the kind illustrated in Fig. 3A. The sarcomeres themselves can
have varying degrees of order; some, like insect flight muscle and bony fish
muscle, are almost ‘‘crystalline’’ within an A‐band or sarcomere. But,
whatever the muscle, both different myofibrils within a fiber, and different
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2D Fourier transform

• Get experience with the tools
• Explore Fourier pairs
• Test ideas with optical diffraction
• Test ideas with the computer

Jean Baptiste Joseph Fourier
France, 1768 - 1830
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Basics of image processing: 
Fourier transforms of 2D images

Real space

Fourier space
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Phase information 
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http://homepages.inf.ed.ac.uk/rbf/HIPR2/fourier.htm



Basics of image processing: 
Fourier transforms of 2D images

FT

Amplitudes

Phases

iFT

Phase information dominates 
image perception

http://homepages.inf.ed.ac.uk/rbf/CVonline/LOCAL_COPIES/OWENS/LECT4/node2.html

Basics of image processing: 
Fourier filters of images

Real -->Fourier -->Real 

http://sharp.bu.edu/~slehar/fourier/fourier.html

Low-pass filter

High-pass filter
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Fourier Rules

 

F(u) = f (x) !e"i2#u !xdx$
F(u) = f (x) ! cos(2#u ! x)" i sin(2#u ! x)[ ]dx$
F(u) = FT ( f (x))
                 f (x) = FT "1(F(u))

Inverse Fourier transformation exists.

more Fourier Rules

 

a !F(u) = FT (a ! f (x))
If you put more contrast in the image, 

then the FFT’s amplitude gets stronger.

 

F(u)+G(u) = FT ( f (x)+ g(x))
Adding two images f and g and calculating their FFT 

is like adding the FFTs F and G of them.

If you rotate and image, 
then you also rotate its FFT.

 

rotated  F(u) = FT (rotated  f (x))

If you stretch an image by a, 
then you shorten the FFT by a.

(===> reciprocity)

 

F(u /a) = FT ( f (ax))



Real space Fourier space
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Linearity theorem

 

FT(a ! f (x,y) + b ! g(x,y)) = a ! F(h,k) + b !G(h,k)



Similarity theorem
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Convolution

Convolution of f with g in real space is slow. It can be done much faster by 
multiplying their FFTs, and calculating the inverse FFT of the result.

 

f (x)! g(x) = FT "1 F(u) #G(u)[ ]

“Convolution of a set of spots with a duck produces a set of ducks.” 

 

f (x)! g(x) = FT "1 F*(u) #G(u)[ ]
Cross-correlation of f with g in real space is slow. It can be done much faster by 

calculating their FFTs, calculating the complex conjugate of the first F*, 
multiplying them, and calculating the inverse FFT of the result.

“Cross-correlation of a noisy image of many viruses with a virus-like circular reference 
produces a map with peaks that show where the viruses are.”

Cross-Correlation
“Convolution of a structure map with a PSF produces a CTF-affected image.   => deconvolution” 
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2D lattice
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A lattice is assembled from many identical proteins, the motif. 
This is mathematically achieved by convoluting the motif with a 

2D comb function that is a 2D point lattice. 

=

The convolution theorem gives the rule for the Fourier transform

 

[ f ! g](x,y)" F(h,k) #G(h,k)

motifcomb function crystal



What the FFT 
can tell us

Spot positions Unit cell size and shape
Spot size Size of coherent domains

Intensity relative to background Signal to noise ratio
Distance to farthest spot Resolution

Amplitude and Phase of spots Structure of molecules
Radius of Thon rings Amount of defocus

Ellipticity of Thon rings Amount of astigmatism
Assymetric intensity of Thon rings Amount of instability

Direction of assymetry Direction of instability

(After David deRosier, 2006)
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Concepts such as Fourier transformation, convolution and resolution that are

required to understand crystallography are illustrated through visual examples.

These concepts can be explained pedagogically in a very direct way using the

DigitalMicrograph software from Gatan Inc. (http://www.gatan.com/imaging/

downloads.php), originally intended for electron microscopy data collection and

analysis, and practical exercises developed around this tool can be used in

teaching crystallography.

1. Introduction

Teaching crystallography implies the development of concepts

such as Fourier transformation, convolution, resolution etc.

that are not necessarily obvious for beginners. In order to help

students new to this field, some interactive web sites have been

created (e.g. Schoeni & Chapuis, 2006) and practical exercises

using the Mathematica software were recently developed by

Dumas et al. (2006). Practicals were also developed in Nancy

University for the ‘Signal Processing’ lectures intended for

second-year university students (Licence Science de la Vie L2)

and for the National CNRS Thematic School ‘Structural

Analysis by X-ray Diffraction, Crystallography under Pertur-

bation’, held in Nancy in September 2006 (http://www.lcm3b.

uhp-nancy.fr/nancy2006/).

In single-crystal X-ray diffraction and under kinematic

conditions, the amplitude of the X-ray beam diffracted by a

crystal of electron density �ðrÞ is given by

EðHÞ ¼ Ee FðHÞ�ðHÞ; ð1Þ

where Ee is the amplitude scattered by one electron, �ðHÞ is

the interference function giving rise to the sharp Bragg

diffraction peaks, and

FðHÞ ¼
Z

cell

�ðrÞ expð2�iH � rÞ dr ð2Þ

is the structure factor associated with the reciprocal-lattice

vector H. Since it is the Fourier transform of the thermally

smeared electron density, the structure factor contains infor-

mation about the unit-cell content (the motif composition).

The diffracted intensities for a crystal composed of a large

number of unit cells are then determined by

IðHÞ / FðHÞ�� ��2¼ FðHÞF�ðHÞ: ð3Þ

The structure factors are the Fourier coefficients of the elec-

tron density �ðrÞ of the motif inside the unit cell:

�ðrÞ ¼ 1

Vcell

X
H

FðHÞ expð�2�iH � rÞ: ð4Þ

Structure factors are generally complex quantities and can be

represented in polar form:

FðHÞ ¼ FðHÞ�� �� exp½i’ðHÞ�; ð5Þ
with the modulus FðHÞ�� �� and the phase ’ðHÞ.

However, according to (3), the diffraction process leads to

the determination of only the moduli FðHÞ�� ��, the information

about the phase being lost. Specialized experimental techni-

ques such as multi-beam X-ray diffraction or convergent-

beam electron diffraction offer possibilities to measure rela-

tive phases between some structure factors (see for example

Spence & Zuo, 1992).

Moreover, it is not possible to measure all Fourier coeffi-

cients of the electron density, firstly because of spatial

limitations around the diffractometer (the diffraction angle

has maximum practical value 2�max < 180�, depending on the

experimental setup), and secondly because one uses nonzero

wavelength � (from the Bragg law the reciprocal resolution is

Hj j=2 ¼ sin �=�, and since � is finite the resolution cannot be

infinite).

This paper aims to present examples that can be used to

illustrate graphically Fourier transform properties in crystal-

lography courses, introducing notions such as resolution,

convolution and signal-to-noise ratio using the free (time-

limited licence) demo version of a very simple but never-

theless powerful software (DigitalMicrograph from Gatan;

http : / /www.gatan .com/imaging /downloads.php), originally

intended for electron microscopy data collection and analysis.

We draw an analogy between a single-crystal X-ray

experiment and manipulation of digital images, as shown in

Fig. 1.

The crystal is replaced by a two-dimensional digital image

that consists of pixels having integer values. It is thus possible

to calculate the Fourier transform (FT) of that two-dimen-

sional image, modifying it with user-friendly tools (e.g.
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removing Fourier coefficients far from the origin) and calcu-

lating to which object it corresponds in direct space.

In the following we will first describe how digital images are

coded and introduce Fourier transformations, and then we will

use the analogy with X-ray diffraction to address some points

about resolution, the phase problem in crystallography, and

the relation between direct and reciprocal space. Finally, an

example showing the important effect of multiple measure-

ments on signal-to-noise ratio will be presented.

Another possible approach is to use Abbe’s theory of image

formation with a rather simple optical bench, and various

examples have been given by e.g. Hecht (2002), Harburn et al.

(1975) and Lipson et al. (1995).

2. Digital representation of an image and its Fourier
transform

The reference image (Fig. 2) is a digital photograph composed

of 256 � 256 pixels coded in 8 bit greyscale [i.e. pixels have

integer values from 0 (black) to 255 (white)]. All images used

in this practical are in 8 bit greyscale TIFF format and are

opened with the pull-down menu option File > Open, or are

directly downloaded using the browser. As shown in Fig. 2, the

mouse pointer is on an almost dark (value = 2) pixel of

coordinates (x, y) = (211, 78).

The Fourier transform of an I(n, m) image is defined as

Fðh; kÞ ¼
XN�1

n¼0

XN�1

m¼0

Iðn;mÞ exp½ð2�i=NÞðhn þ kmÞ� ð6Þ

(with N = 256 in our example), which is similar to the defini-

tion of the structure factor from the electron density [equation

(2)]. The inverse Fourier transform is

I n;mð Þ ¼ 1

N2

XN=2�1

h¼�N=2

XN=2�1

k¼�N=2

F h; kð Þ exp½�ð2�i=NÞ hn þ kmð Þ�:

ð7Þ
In the following we will limit ourselves to real I(n, m) signals

[in our analogy the electron density �ðrÞ is a real quantity],

which implies that F�ðh; kÞ ¼ Fð�h;�kÞ. Moreover, in order

to use the fast Fourier transform algorithm implemented in

DigitalMicrograph, these images must have square N � N

pixel sizes with N a power of two.

Fourier transform calculations can be illustrated on a

smaller image (Fig. 3a), composed of only 4 � 4 pixels. Table 1

displays the integer values of each of the 16 pixels, and Table 2

(visualized in Fig. 4) displays the values of the corresponding

Fourier coefficients [note the origin definition (h = 0, k = 0)].

As can be seen from Table 2 and generalizing to an N � N

pixel image, the centre of the Fourier transform (h, k) = (0, 0)

is placed at the (N/2 + 1)th row and column. This implies, as

the original image and its Fourier transform are N � N, that all

Fourier coefficients are related by a complex conjugate rela-

tionship centrosymmetric about (0, 0), except those in the first

row (k = �2) and column (h = �2).

teaching and education

1154 Aubert and Lecomte � Illustrated Fourier transforms J. Appl. Cryst. (2007). 40, 1153–1165

Figure 1
Analogy between single-crystal X-ray diffraction and image manipula-
tion. The bright spot at the centre of the Fourier transform (FT) of the
photograph directly corresponds to the F(0, 0, 0) spot in the diffraction
pattern. The diffraction pattern of a crystal is composed of peaks as a
result of the periodicity of the crystal (top), whereas the photograph is a
‘single’ object: its FT is ‘continuous’ (bottom).

Figure 2
Our reference image opened in DigitalMicrograph is composed of 256 �
256 pixels coded in 28 greyscale values, from 0 (black) to 255 (white).

Figure 3
(a) A small 4 � 4 pixel image. (b) Moduli of the Fourier coefficients of
Fig. 3(a); symmetry is visible around (h, k) = (0, 0). (c) Phases of the
Fourier coefficients of Fig. 3(a); antisymmetry is visible around (h, k) = (0,
0). Maximum (minimum) values of moduli and phases are white (black).
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3. Significance of the Fourier coefficients of an image

In order to illustrate the significance of the Fourier coefficients

of an image, it is possible to look at which image corresponds

to a limited number of Fourier coefficients. As a first example

we start from an all-zero 16 � 16 complex image and then set

F(�1, 0) = 1 � i, F(1, 0) = 1 + i and calculate its inverse Fourier

transform (see Appendix A, xA1 for the procedure in Digi-

talMicrograph). This leads to the horizontal sine wave of

lowest frequency displayed in Fig. 5(a). Then, using F(�h, 0)/

F(h, 0) couples, further and further from (0, 0) (Figs. 5b and

5c), one sees that these conditions correspond to sine waves of

increasing frequencies. The highest frequency is a special case

(Fig. 5c), coded only in one Fourier coefficient, i.e. F(�8, 0);

this special treatment for the highest-frequency coefficients

simply allows the use of arrays of identical sizes (N � N) for

the images and their Fourier transforms. Starting from equa-

tion (7) and setting Fðh; 0Þ ¼ Fj j expði’Þ, one finds the same

results, the recomposed image being

I n;mð Þ ¼ ð1=162Þ� Fj j expð�i’Þ exp ð�2�=16Þið�hn þ 0mÞ½ �
þ Fj j expði’Þ exp ð�2�=16Þiðhn þ 0mÞ½ ��

¼ ð1=162Þ Fj j 2 cos ð2�=16Þhn � ’½ �:
The complicated image represented in Fig. 2 can thus be seen

as resulting from the interference (sum of amplitudes taking

into account the relative phases) of the different sine waves

generated from each F(h, k)/F(�h, �k) pair. This example

also illustrates that Fourier coefficients close to the origin

(0, 0) bear information on large-scale intensity variations

across the image, whereas the F(h, k) far from the origin

encode precise details of the image (this point will be further

developed in x4).

3.1. Dirac delta function and convolution

The two-dimensional Dirac delta function �ðx� x0Þ
(defined in real space) is non-zero only at position x0; one of

its properties is to select the value at x0 of a given function

f ðxÞ:
Z Z

f xð Þ � x� x0ð Þ dx ¼ f x0ð Þ:

If the Dirac function is centred on the origin [x0 ¼ ð0; 0Þ], the

Fourier representation of digital images given in x2
[�ð0; 0Þ ¼ 1] gives the Fourier transform as simply

FT �ðn;mÞ� � ¼
XX

�ðn;mÞ exp ð2�i=NÞðhn þ kmÞ½ � ¼ 1:

Thus the Dirac delta function [�(0, 0) = 1] is the inverse

Fourier transform of the constant 1:
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Table 1
Pixel values of Fig. 3(a).

n

m 0 1 2 3

0 127 46 255 241
1 176 179 70 241
2 183 5 190 243
3 196 157 136 94

Table 2
Fourier transform of Fig. 3(a).

A complex conjugate relationship (in italics) is visible around the F(0, 0)
Fourier coefficient (bold). A graphical representation is given in Fig. 4.

h

k �2 �1 0 1

�2 313 + 0i �301 + 434i 41 + 0i �301 � 434i
�1 �30 + 255i 4 � 89i 48 � 83i �246 � 3i
0 127 + 0i 31 + 432i 2539 + 0i 31 � 432i
1 �30 � 255i �246 + 3i 48 + 83i 4 + 89i

Figure 4
Representation in the complex plane of two F(h, k) Fourier coefficient
couples from Table 2.

Figure 5
Complex arrays (upper row, 16 � 16 Fourier coefficients) with only some
nonzero Fourier coefficients appearing as white squares (they are Dirac
peaks, defined in x3.1), and corresponding images obtained by inverse
Fourier transformation (lower row, 16 � 16 pixels). (a) Lowest-frequency
horizontal sine wave; (b) intermediate-frequency sine wave; (c) highest-
frequency sine wave.

electronic reprint



�ðn;mÞ ¼ 1

N2

XN=2�1

h¼�N=2

XN=2�1

k¼�N=2

exp ð�2�i=NÞðhn þ kmÞ½ �:

The convolution between two two-dimensional functions f ðxÞ
and gðxÞ is defined by

f � gð Þ uð Þ ¼
Z Z

f u� xð Þ g xð Þ dx;

and the convolution theorem relates the Fourier transform of

the convolution product to the product of the Fourier trans-

forms of the original functions:

FT f � gð Þ uð Þ� � ¼ FT f xð Þ� �
FT g xð Þ� �

:

As an example, Fig. 6 displays the convolution between a two-

dimensional Gaussian function centred at position (x, y) =

(200, 200) on a 1024 � 1024 pixel grid, and an image made of

four Dirac peaks located at (100, 300), (400, 200), (300, 300)

and (450, 450) pixels coordinates (see xA2). The final image is

calculated in this example using the convolution theorem, but

the result can be seen as being obtained by ‘applying’ the

Gaussian function to the four Dirac peaks, taking into account

that the Gaussian function is shifted from the origin.

From a mathematical point of view, this corresponds to

[with one Gaussian gðxÞ centred at x1 and one Dirac peak

centred at x0]

�� gð Þ uð Þ ¼
Z Z

� u� x� x0ð Þ exp � x� x1ð Þ2
� �

dx

¼ exp � u� x0 � x1ð Þ2
� �

i.e. a Gaussian centred at x0 þ x1.

3.2. Patterson function

In crystallography, the Patterson function PðuÞ, used to

solve structures containing heavy atoms, is defined as the

autocorrelation function of �ðrÞ, or in other words as the

convolution of �ðrÞ with �ð�rÞ:
PðuÞ ¼ �ðrÞ � �ð�rÞ

¼
Z

�ðrÞ �ðuþ rÞ dr:

One important property of PðuÞ is that its Fourier transform is

simply

FT P uð Þ� � ¼ Fj j2; P uð Þ ¼ FT�1 Fj j2� �
;

that is to say that unlike electron density �ðrÞ, this function can

be directly computed from experimental IðHÞ / FðHÞ�� ��2
data

by inverse Fourier transformation.

Starting from the previous image (Fig. 6) composed of the

four Gaussian functions that can be seen as analogous to a

four-atom structure, the Patterson function can be calculated

in different ways, given in xA3. The resulting Patterson func-

tion is shown in Fig. 7; it displays 12 peaks around the origin

(image centre) corresponding to the N2 � N = 12 interatomic

vectors for the N = 4 ‘atoms’.

4. Resolution

4.1. Resolution: aesthetic and quantitative point of view

Starting from the original image (Fig. 2), one wonders how

it will be modified if one keeps only a selected part of its

Fourier transform. In order to perform such modifications, we

use masking tools such as those indicated in Fig. 2 (xA4).

The results using a circular masking tool, displayed in Fig. 8,

illustrate that the Fourier coefficients far from the origin

(centre of the FT) encode details of the image such as the leafs

behind the statue, whereas the Fourier coefficients close to the

origin encode large-scale intensity variation (e.g. the statue is

white on dark background forest).

For a more quantitative approach we consider Fig. 9(a) (256

� 256 pixels), composed of two black disks (15 pixels in

diameter) separated by 40 pixels, and ask what is the minimal

number of Fourier coefficients that is required for the two

disks to be visually separable?

One can consider that the lowest frequency necessary to

distinguish the two disks corresponds to a sine wave having a

periodicity equal to the separation between the disks. From

the first part we know that the first

Fourier coefficient close to the origin

corresponds to a sine wave of one

period on the image, i.e. 256 pixels.

Thus the sine wave with a period of 40

pixels corresponds to the sixth or

seventh Fourier coefficient starting

from the origin (256/40 = 6.4). Indeed,

as displayed in Fig. 10(a), the image

reconstructed using only a central area

of the first five Fourier coefficients in

radius does not permit one to distin-
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Figure 6
Convolution of a two-dimensional Gaussian function with four Dirac peaks.

Figure 7
Patterson function (b) of the four ‘atoms’ (a).
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guish the two disks, whereas the image calculated with eight

Fourier coefficient radii clearly allows one to conclude the

presence of two objects on the original image.

In our analogy these disks can be seen as two atoms; the

shortest interatomic distance that one can expect in a

compound is, for example, a C—H bond (	1 Å). Using the

Bragg law 2d sin � ¼ � and with d = 1 Å, one deduces that the

X-ray diffraction experiment has to collect diffracted beams

up to diffraction angle sin �=� ¼ 0:5Å
�1

[corresponding to

2� ’ 41� for Mo K� radiation (� = 0.711 Å)] in order to

distinguish H atoms from their neighbours.

4.2. Interpretation of the aesthetic effect of resolution using

the convolution theorem

The blurred appearance of the low-resolution image in

Fig. 8(b) can be explained using the convolution theorem. This

image is the inverse FTof the FTof the

original image (Fig. 8a), of which we

only kept a circular central area. This

modified FT can be considered to be

the simple product in reciprocal space

of the FT of the original image and a

circular mask displayed in Fig. 11(b).

In direct space, the fuzzy image in

Fig. 11( f) is thus the convolution of

the original image and the inverse FT

of the circular mask (more examples

of FTs of simple objects are given

in x6).

Indeed, the inverse FT of the

circular mask (Fig. 11e) is character-

ized by four peaks surrounded by

oscillations that rapidly decrease in

magnitude. It should be noted that the

most important contribution to the

final image (Fig. 11f) arises from the

top-left peak corresponding to the

coordinate origin (the three other

peaks at the corners create duplicate

images outside the boundary of the

display but may lead to some artefact

close to the edges of the image). The convoluted final image

(Fig. 11f) can thus be seen as the sum of copies of the original

image shifted and weighted according to the shape of

Fig. 11(e). In the limiting case of an infinite mask (thus no

masking), the inverse FT of the mask is simply a Dirac peak

centred on the top-left corner, and the resulting image is then

identical to the original one (convolution of the original image

with a Dirac peak placed at the origin). If the mask narrows in

reciprocal space, its inverse FT widens in direct space (see x6),

with increasing contributions far from the top-left corner, and

blurring is more and more pronounced in the final image. In

teaching and education

J. Appl. Cryst. (2007). 40, 1153–1165 Aubert and Lecomte � Illustrated Fourier transforms 1157

Figure 8
Original image (a) and its Fourier transform (d ); low-resolution image (b) corresponding to the FT
(e) (with the central zone magnified in the bottom-right inset); high-resolution image (c)
corresponding to the FT ( f ).

Figure 10
Images (and horizontal profiles) recomposed from the FTs of Fig. 9(a) on
which we selected only a central circular area of five [(a) and (c)] or eight
[(b) and (d )] Fourier coefficients in radius.

Figure 9
Image composed of two black disks separated by 40 pixels (a) and its
Fourier transform (b).
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the other limiting case the mask is reduced to a single Dirac

peak of height 1, of which the inverse FT is a constant image

(1/N2). In that case the original image is ‘totally’ blurred,

leading to an image having a constant value (which is the

average value of the original image).

4.3. Resolution in crystal structure analysis

Assuming that an X-ray diffraction experiment allows the

determination of all structure factors in moduli and phases up

to 1 Å�1, then, according to the Bragg law, the smallest

observable detail without using a model for the structure is

0.5 Å. However, in structure reports, typical estimated stan-

dard deviations in C—C bond lengths, for example, are of the

order of 0.002 Å, which is far below the diffraction limit. This

‘extra resolution’ is induced by the model inserted to fit the

observations (and solve the phase problem); the crystal is

composed of atoms of known (usually spherical) shapes. This

extra resolution may be misleading because it is strongly

linked to the model, and this is not unique; usually one uses

spherical atoms (independent atom model, IAM) to model

X-ray diffraction data, but atoms are not spherical because of

chemical bonds with their neighbours. This asphericity of the

valence electron density may be taken into account in more

sophisticated atomic models [e.g. multipolar models (Stewart,

1976; Hansen & Coppens, 1978)] and offers precise char-

acterization of interatomic and intermolecular interactions

(Lecomte et al., 2005). Bond distances may be significantly

different between the IAM and multipolar models.

Dahaoui (2007) and Espinosa et al. (1997) performed charge

density studies of complexes of tetracyanoquinodimethane

(TCNQ) with different molecules [benzidine: BD-TCNQ;

p-terphenyl: PTP-TCNQ; bis(thiodimethylene)tetrathia-

fulvalene: BTDMTTF-TCNQ; see Appendix B]. Using exactly

the same data for IAM and multipolar models on these

compounds, the cyano bond distances in TCNQ were

1.1604 (7), 1.1602 (7) and 1.1615 (9) Å for mutlipolar models

of BD-, PTP- and BTDMTTF-TCNQ, respectively, but ‘only’

1.1539 (9), 1.1532 (7) and 1.1551 (10) Å for the corresponding

IAM models. These bond lengths differ between the two

atomic models by as much as �/� = 7.2, 10 and 6.4 for BD-,

PTP- and BTDMTTF-TCNQ, respectively, � being the larger

bond length standard deviation from the two models. The

reason for these significant discrepancies between IAM and

multipolar models is illustrated in Fig. 12, where the static

deformation density through the TCNQ molecular plane is

plotted. This density is defined as the difference between the

electron density derived from the multipolar model and the

teaching and education

1158 Aubert and Lecomte � Illustrated Fourier transforms J. Appl. Cryst. (2007). 40, 1153–1165

Figure 12
Static deformation density of TCNQ (multipolar density minus IAM
density) showing the redistribution of valence electrons as a result of
chemical bonding (contour intervals are at the 0.1 e Å�3 level; solid lines
are positive, dotted lines are negative, and the zero contour is dashed)
(Dahaoui, 2007).

Figure 11
The images of the lower row are inverse FTs of the corresponding upper-row images.
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electron density of the corresponding IAM model, and thus it

shows the redistribution of valence electron density due to

chemical bonding. As can be seen from this figure, the valence

density in C
N bonds is strongly shared between the two

atoms, leading to a substantial displacement of the electronic

centroids of both the C and the N atoms and therefore to a

biased bond length if an IAM model is used.

Consistent with that finding but in a different way, Seiler et

al. (1984) showed that, for a given refinement model, struc-

tural parameters depend on the data set extension used

to refine these parameters. Their compound (tetrafluoro-

terephthalonitrile) also possesses a C
N bond whose length

converged from an IAM refinement to 1.1489 (8) Å using all

of the structure-factor data set (sin�/� < 1.15 Å�1); however,

this distance increased to 1.1538 (4) Å if only high-order data

were used (0.85 Å�1 < sin�/� < 1.15 Å�1). This under-

estimation of bond lengths when using an IAM model is

explained by the fact that valence electrons (responsible for

biased interatomic distances) contribute mainly to low-order

reflections (see x6 for an explanation of valence/core contri-

butions to diffraction).

This biasing of bond distances is mainly encountered in

strongly polar interactions, where the electron density is

shared between atoms. An even more obvious example is

X—H bonds (X = C, N, O), in which the distance can be

underestimated by as much as 0.1 Å when using an IAM

model. Because H atoms have their electronic clouds strongly

deformed in such bonds, one must use neutron nuclear

diffraction (where neutrons interact with nuclei, not with

electrons) to perform a precise structure determination or

charge density modelling.

5. Phase and modulus

In this section we consider the relative importance of the

modulus and phase of the Fourier coefficients. Starting from

two images (Figs. 13a and 13b), one can extract the moduli and

phases of their respective Fourier transforms and recombine

them (modulus of FT of image a with phase of FT of image b

and reciprocally; see xA5.1). As shown in Fig. 14, the images

obtained are closer to the image from which we took the phase

than that one from which we extracted the modulus.

It is also possible to use random moduli (Fig. 15a) or

random phases (Fig. 15b): one has to note, however, that in

order to obtain real images the relation Fð�HÞ ¼ F�ðHÞ
around (h, k) = (0, 0) must be imposed on these random values

and this could be achieved using more complex scripts (xA5.2).

Each pixel of an image built from a Fourier transform (i.e.

using an inverse Fourier transform operation) is the result of
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Figure 13
Two images (a) and (b), and the Fourier transform of (a) represented as
the log of its modulus (c) and its phases (d ).

Figure 14
Images obtained by combining the moduli and phases of the FTs of the
images given in Figs. 13(a) and 13(b): (a) moduli of Fig. 13(b) and phases
of Fig. 13(a); (b) moduli of Fig. 13(a) and phases of Fig. 13(b). This shows
that the phases are more important than the moduli.

Figure 15
Image (a) composed with random moduli and phases of image Fig. 13(a);
Image (b) composed with random phases and moduli of image Fig. 13(a).
This shows that phases are more important than moduli.

Figure 16
The intensity at a pixel is proportional to the sum of the Fourier
coefficients [here ’(h, k) includes the spatial propagation phase term].
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the interference (addition in the complex plane) of the

contributions of each Fourier coefficient (Fig. 16). If phases

are strongly modified, the resulting amplitude will be strongly

affected. Comparing Fig. 14(a) (created with moduli of

Fig. 13b) and Fig. 15(a) (created with random moduli), one can

easily see that the former is closer to the original image

(Fig. 13a); this is explained by noting that the moduli of

Fig. 13(b) ‘resemble’ more closely the moduli of the original

image Fig. 13(a) (with a central strong peak and decreasing

Fourier coefficients away from the centre), whereas the

random moduli used here are uniform in reciprocal space.

The importance of the phases relative to the moduli is also

evidenced by repeating these examples with different sets of

random phases or moduli. Whereas the images (not shown

here) composed with random moduli are aesthetically very

similar (one can recognize the edges of the statue), the images

obtained with random phases are clearly different from one

another and do not resemble the original object.

6. Shape and symmetry relations between direct and
reciprocal space

6.1. Fourier transformation of individual objects

In order to explain, for example, the ‘shape’ of the Fourier

transform of a crystal or the contributions of core and valence

electron densities to diffraction, one must illustrate the rela-

tions between direct and reciprocal space.

Fig. 17 underlines the well known Fourier transform prop-

erty that a shape-restricted object (direct space) corresponds

to an extended Fourier transform and vice versa (Figs. 17a–

17d). Also evident is the symmetry relationship between the

two spaces: a cylindrical object (Fig. 17a) will have a cylind-

rical FT (Fig. 17b); a rectangular object (Fig. 17e) will have an

FT (Fig. 17f) that is an assembly of rectangles but with their

smallest extension in the same direction as the greatest

dimension of the object. The polygon displayed in Fig. 17(g)

has then an FT characterized by tails perpendicular to its

edges, since this object has restricted extension along these

directions [the five edges of the polygon give rise in the FT

(Fig. 17h) to five tails crossing at the origin]. Remembering

images of the sun recorded in movies (often observed as a disk

surrounded by six tails), one recalls that usually hexagonal

diaphragms are used in front of the camera.

Starting from Fig. 17(e) one can see that the FT of an infinite

vertical slit is obtained from Fig. 17( f) where the horizontal

oscillations are kept (they are linked to the slit width) but the

vertical ones are condensed in the horizontal direction.

Adding a second vertical slit leads to interference (Young’s

two-slit experiment), where the spacing between the minima is

linked to the slit separation (Fig. 18d). If more and more

equidistant slits are inserted, secondary maxima of decreasing

height are created between the principal maxima, which

sharpen, and in the limiting case of an infinite number of slits

giving rise to a lattice, the Fourier transform becomes a Dirac

row (Fig. 19).

A two-dimensional lattice can then be constructed by

crossing vertical and horizontal one-dimensional lattices, as

displayed in Fig. 20(a). This lattice being infinite, its Fourier

transform is then also a lattice [in Fig. 20(b) the Dirac peaks

are artificially enlarged for clarity]. The direct lattice (Fig. 20a)

can be seen as the convolution of a Dirac peaks lattice and the

motif composing the ‘unit cell’ (Fig. 20d): indeed, its Fourier

transform is the simple product between the reciprocal lattice

(FT of the direct lattice) and the FT (Fig. 20e) of the motif

(Fig. 20d). The two black horizontal lines In Fig. 20(b) arise
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Figure 17
Relations between direct and reciprocal space. To a small disk (a) corresponds a large Fourier transform (b) and vice versa [(c) and (d )]. A rectangular
object (e) gives rise to a rectangular FT ( f ), the largest extension of which corresponds to the thinner direction of the object. A complex object such as
the polygon (g) results in an FT (h) (with the central zone magnified in the bottom-right inset), having extensions in directions perpendicular to the faces
of the object.
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from the fact that a node of the FT (Fig. 20e) falls on the same

position as a row of the reciprocal lattice that samples this

function.

Returning to crystallography, the crystal is the convolution

of a three-dimensional direct lattice with a motif that describes

or ‘decorates’ the unit cell; its Fourier transform (related to

the diffraction pattern) is then the simple product of the

reciprocal lattice, giving rise to sharp diffraction spots [it is the

interference function �ðHÞ of equation (1) in the case of a

large number of unit cells], with the FT of the motif, which is

the structure factor FðHÞ which leads to intensity variations

from spot to spot and to (non-lattice) systematic extinctions.

The structure factors are the sum of the contributions of the

Nat different atoms composing the unit cell:

F Hð Þ ¼
XNat

j¼1

fj Hð Þ exp 2�iH � rj

� �
;

where fjðHÞ is the atomic scattering factor of atom j and is the

Fourier transform of its electron density. Electrons of non-H

atoms may be defined as core and valence electrons and have

distinct contributions in reciprocal space because of their

different locations in real space. As shown in Fig. 21 the iron

core electrons tightly bound to the nuclei contribute in the

whole diffraction angle range, whereas valence electrons

spread in direct space have noticeable contributions only for

small diffraction angles, i.e. close to the origin of the reciprocal

space owing to the FT properties. This implies that in charge

density (in which one wants to observe and model the distri-

bution of valence electrons) or accurate thermal motion

studies one has to collect accurately low- and high-diffraction-

angle reflections in order to distinguish valence effects from

thermal displacements (static or dynamic) since the FT of the

structure factors is the thermally smeared electron density

(Coppens, 1997) [see Aubert et al. (2003, 2004) for an example

of charge density and electrostatic potential studies].

6.2. Effect of the crystal shape

In single-crystal X-ray diffraction a typical size of the

specimen is about 100 mm in length in each direction, the

optimal size being a compromise between the diffracting

power proportional to the crystal volume and the absorption

phenomenon. Crystal size has a less important effect with the
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Figure 20
Two-dimensional lattice (a) and its Fourier transform (b). The intensity
variation (c) across the horizontal line of (b) arises from the Fourier
transform (e) of the motif (located in any unit cell) (d ), which decorates
the lattice (a).

Figure 19
Fourier transform (b) of a one-dimensional vertical lattice (a) (the width
of the Dirac peaks is exaggerated for clarity).

Figure 18
From slits to lattices. The combination of two slits (a) leads to
interferences (d ), where the spacing between minima is linked to the
slit separation. Adding more and more slits [(b) and (c)] creates
secondary maxima of decreasing intensity between the principal maxima
[(e) and ( f )].
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X-ray technique than it has in electron diffraction, where the

crystal must be very thin to be transparent to the electron

beam (Williams & Carter, 1996).

Given the infinite perfect crystal displayed in Fig. 22(a), one

wonders how its diffraction pattern will be modified if its

shape is changed. Because the crystal is infinite, its Fourier

transform is a regular array of Dirac peaks of varying heights

across the image.

According to what was seen in the preceding section, if one

restricts the object shape in one direction its Fourier transform

will expand in that direction. Examples of different crystal

shapes are given in Fig. 23, together with their Fourier trans-

forms. These latter can be explained using the convolution

theorem: in direct space, the finite size crystal can be seen as

the simple product of the infinite crystal with a mask giving the

crystal shape; in reciprocal space the Fourier transform of the

finite crystal is then the convolution of the Fourier transform

of the infinite crystal (array of Dirac peaks) by the Fourier

transform of the mask.

6.3. Playing: bird in cage . . .

As a recreation, one can play with the well known example

of the captive bird shown in Fig. 24(a), the aim being to release

the flying animal. As displayed in Fig. 24(b) one can recognize

the respective contributions of the bird (complex intensity

variation with a global decreasing from the origin) and of the

cage (which is a simple vertical one-dimensional lattice) giving

rise to sharp spots in the equatorial line. The bars of the cage

will then disappear if one masks their contributions in the

reciprocal space as in Fig. 24(c). The final image still displays

traces of the bars because the cage contribution spreads

beyond the section that was hidden. In direct space, the

original image is the simple product of the bird and of the

cage; thus in reciprocal space it corresponds to the convolution

of the FT of the bird on the Dirac peaks of the FT of the cage.

7. Signal on heavy noise

As a final application, we present an example related to

electron microscopy; in Fig. 25(a) are displayed 20 objects that

are assumed to be identical and related by translation only (i.e.

no rotation). As can be seen, the high noise level allows the

identification of these objects on the image but precludes the

observation of the possible details inside them. Because the

noise is assumed to be random across the image, one can thus

average the 20 objects in order to increase their signal to noise

ratio (xA6).

The first step is to find the precise position of each object on

the image; one extracts one of the objects (Fig. 26a) and

computes the cross correlation between this extracted object

and the full image. The result, shown in Fig. 26(b), displays

sharp peaks corresponding to the repetitive positions of the

extracted object on the original image (these peaks give the
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Figure 23
A rectangular crystal (a) and its Fourier transform (b). The extension of
the FT is larger in the direction where the crystal is thinner. A spherical
crystal (c) and its Fourier transform (d ). The Fourier transforms are the
convolution of the FT of the infinite crystal with the FT of the shape of the
finite crystal.

Figure 22
An infinite perfect crystal (a) and its Fourier transform (b).

Figure 21
Atomic scattering factor of Fe and Fe3+ as a function of diffraction angle
�. These two curves only significantly differ for low diffraction angles
where the contribution of valence electrons is the strongest.

electronic reprint



coordinates in the image frame of the top-left corner of the

square selection that have to be used to extract and average

the 20 objects). The average image (Fig. 27 after adequate

rotation) is then obtained by summing the objects extracted

from the original image using the coordinates derived from the

cross correlation; it reveals the weak signal hidden by the high

level noise.

This example of utilization of correlation also illustrates the

importance of multiple measurements of structure factors in

single-crystal X-ray diffraction in order to increase their

signal-to-noise ratio. This is of the utmost importance, for

instance, in charge density modelling, where the effect to be

observed (i.e. electron density reorganization owing to

chemical bonding) is weak.

8. Conclusions

This paper illustrates the Fourier transformation and its

properties used in crystallography with emphases on X-ray

diffraction. Obviously, the demonstrations are not restricted to

crystallographic applications but are relevant to all domains

where Fourier transformation, convolution, correlation, reso-

lution etc. are important. The example of X-ray imaging that

uses synchrotron and the promising free electron laser sources

is particularly relevant. Figs. 17(b) and 17( f) of the present

paper correspond to Figs. 7 and 8 of the Livet lead article on

diffraction with an X-ray coherent beam (Livet, 2007).

Some other examples of image manipulations are given at

http://www.lcm3b.uhp-nancy.fr/lcm3b/Pages_Perso/Aubert/

sommaire.html. These illustrations show, for example, how to

use Fourier transform for zooming on an image or to insert a

digital signature into a photograph.

The free demonstration version of DigitalMicrograph soft-

ware is available from Gatan (http://www.gatan.com/imaging/

downloads.php).
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Figure 24
How to release a captive bird. The original image is in (a) and its FT in
(b). By removing with a mask part of the contribution of the bars in the
FT (c) the cage ‘disappears’ in direct space (d ).

Figure 25
(a) 20 identical objects are spread on a random high-level noise. (b)
Zoom on three objects; the noise level precludes any signal detection
inside the objects.

Figure 26
(a) One extracted object placed in a new otherwise zero image. (b) Cross
correlation between the original image (Fig. 25a) and the extracted
object (a).

Figure 27
Average of the 20 objects extracted from Fig. 25(a) (after 120� rotation),
revealing the weak signal hidden in the noise.
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APPENDIX A
Procedures and scripts used for the examples
developed in the text

A1. (x3. Significance of the Fourier coefficients of an image)

File > New > Width 16 Height 16 Complex 8 Bytes

Constant (0)

Object > Display Type > Spreadsheet

Modify F(h, k) by double click on it

Object > Display Type > Raster

Process > Inverse FFT

Object > Display > Complex Display Real Part

A2. (x3.1. Convolution)
File > New > 1024 1024 Real 4 Ramp X ) Image A

File > New > 1024 1024 Real 4 Ramp Y ) Image B

File > New > 1024 1024 Real 4 Constant 0 )
Image C

File > New > 1024 1024 Real 4 Constant 0 )
Image D

In one script:

c = exp(-1e-3*((a-200)**2+(b-200)**2))

d = 0

d[100,300] = 1

d[400,200] = 1

d[300,300] = 1

d[450,450] = 1

Process > FFT on images C and D (results in E and F)

Process > Simple Math > E*F (results in G)

Process > Inverve FFT on G (results in H)

Edit > Change Data Type > Real > Real Component

A3. (x3.2. Patterson function)

Directly using the implemented function:

Process > Auto correlation (results in I)

Using the convolution theorem:

Process > Rotate 180� (results in J from H)

iFFT on the product of FFT of H and FFT of J

Using the relation P uð Þ ¼ iFT Fj j2� �
: calculate F Hð Þ�� ��2

from H:

Process > FFT (result in J)

Edit > Change Data Type > Real > Modulus

Process > Simple Math > a**b with b = 2 (results

in K)

Edit > Change Data Type > Complex

Process > Inverse FFT

A4. (x4.1. Resolution: aesthetic and quantitative point of

view)

Open image

Process > Fourier Transform

Apply the masking tool to that FT

Process > Apply Mask

Process > Inverse FFT

A5. (x5. Phase and modulus)

A5.1. Open the two images (results in A and B)

Process > Fourier Transform on these two images

(results in A, B ) C, D)

mp = complex(modulus(c)*cos(phase(d)),

modulus(c)*sin(phase(d)))

pm = complex(modulus(d)*cos(phase(c)),

modulus(d)*sin(phase(c)))

A5.2. With random moduli and phases of the Chinese

Musician:

File > New > 256 256 Real 4 Random (image A)

In a script: (image C)

b = a[1,1,256,256]

FlipHorizontal(b)

FlipVertical(b)

c = a

c[129,1,256,256] = b[128,0,255,255]

deleteimage(b)

d = c[128,1,129,256]

FlipHorizontal(d)

c[128,1,129,128] = d[0,0,1,127]

deleteimage(d)

d = c[0,1,1,256]

FlipHorizontal(d)

c[0,1,1,128] = d[0,0,1,127]

deleteimage(d)

d = c[1,0,256,1]

FlipVertical(d)

c[1,0,128,1] = d[0,0,127,1]

deleteimage(d)

Open image of the Chinese Musician (image B)

Process > FFT (image D)

z = complex(c*cos(phase(d)),c*sin(phase(d)))

(image Z)

Process > Inverse FFT (Z ) E)

Edit > Change Data Type > Real > Real Component

(on E)

With random phases and moduli of the Chinese Musician:

File > New > 256 256 Real 4 Random (image A)

In a script: (image D)

b = (a-0.5)*2*pi()

c = b[1,1,256,256]

FlipHorizontal(c)

FlipVertical(c)

d = b

d[129,1,256,256] = -c[128,0,255,255]

e = d[128,1,129,256]

FlipHorizontal(e)

d[128,1,129,128] = -e[0,0,1,127]

deleteimage(e)

e = d[0,1,1,256]

FlipHorizontal(e)

d[0,1,1,128] = -e[0,0,1,127]

deleteimage(e)

e = d[1,0,256,1]
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FlipVertical(e)

d[1,0,128,1] = -e[0,0,127,1]

deleteimage(e)

deleteimage(b)

deleteimage(c)

d[0,0] = 0

d[128,128] = 0

d[0,128] = pi()

d[128,0] = pi()

Open image of the Chinese Musician (image B)

Process > FFT (image C)

z = complex(modulus(c)*cos(d),modulus(c)

*sin(d)) (image Z)

Process > Inverse FFT (Z ) E)

Edit > Change Data Type > Real > Real Component

(on E)

A6. (x7. Signal on heavy noise)

Open the 20 object image (image A)

Draw a square 256 � 256 pixel selection around a given

object

File > New > 2048 2048 Real 4 Constant (a)

(image B)

In a script: b[0,0,256,256] = a[]

Now we have to compute the cross correlation between A

and B:

C uð Þ ¼
Z

A xð ÞB xþ uð Þ dx;

which can be seen as the convolution of AðxÞ with Bð�xÞ.
Process > Rotate (180�) (image B ) image C)

Process > FFT (A ) D)

Process > FFT (C ) E)

Process > Simple Math (D � E ) F)

Process > Inverse FFT (F ) G)

APPENDIX B
Diffraction data

BD-TCNQ: space group: C2/m; temperature: 100 K; sin�/�max

= 1 Å�1; multipolar model: R = 0.023, Rw = 0.024; g.o.f. = 0.605;

IAM: R = 0.038, Rw = 0.049, g.o.f. = 1.208. PTP-TCNQ: space

group: P�11; temperature: 120 K; sin�/�max = 1.09 Å�1; multi-

polar model: R = 0.031, Rw = 0.032, g.o.f. = 1.476; IAM: R =

0.045, Rw = 0.048, g.o.f. = 2.122. BTDMTTF-TCNQ: space

group: C2/m; temperature: 15 K; sin�/�max = 1.14 Å�1; multi-

polar model: R = 0.027, Rw = 0.025, g.o.f. = 0.957; IAM: R =

0.035, Rw = 0.037, g.o.f. = 1.397.
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